Interim slowdown in Dashboard
Incident Report for Punchh
Resolved
Issue has been resolved. We continue to closely monitor all components to ensure there are no further issues.
Posted 10 months ago. Jan 03, 2019 - 08:48 PST
Investigating
We are actively working on fixing the issue of the ​slowdown in Dashboard
Posted 10 months ago. Jan 03, 2019 - 08:34 PST
This incident affected: Management Portal.