Eclub Upload Processing Delays
Incident Report for Punchh
Resolved
Eclub processing has been completed. This incident has been resolved.
Posted Nov 18, 2024 - 22:54 PST
Monitoring
There is a delay in Eclub processing. The estimated completion time is 12am PST
Posted Nov 18, 2024 - 16:30 PST