Maintenance: Dashboard search might return stale results
Incident Report for Punchh
Resolved
This incident has been resolved. We continue to closely monitor all components to ensure there are no further issues.
Posted 7 months ago. Mar 18, 2019 - 03:39 PDT
Investigating
Due to maintenance activity, dashboard search might return stale results.
Posted 7 months ago. Mar 18, 2019 - 02:51 PDT
This incident affected: Dashboard.