Interim slowdown in Dashboard Stats

Incident Report for Punchh

Resolved

This incident has been resolved.
Posted Feb 18, 2020 - 18:22 PST

Update

We are continuing to work on a fix for this issue.
Posted Feb 18, 2020 - 18:11 PST

Identified

We are actively working on fixing the issue of the ​slowdown in Dashboard
Posted Feb 18, 2020 - 18:10 PST