Punchh Platform Outage

Incident Report for Punchh

Resolved

This incident has been resolved.
Posted Aug 17, 2025 - 00:00 PDT

Monitoring

A fix has been implemented to address the issue impacting the Punchh Platform. Our engineering team has confirmed that the platform is working fine, and we are closely monitoring the system to ensure continued stability and normal operations. We will provide further updates if any additional issues arise.
Posted Aug 16, 2025 - 23:09 PDT

Identified

We have identified the root cause of the issue affecting the Punchh Platform and our engineering team is actively working on implementing a fix. We are treating this as a top priority and will share an update once the fix is in place or if there are any significant developments.
Posted Aug 16, 2025 - 22:58 PDT

Update

Our team is actively investigating the root cause of the issue impacting the Punchh Platform. We are working to identify and resolve the underlying problem as quickly as possible and will provide further updates as soon as more information becomes available.
Posted Aug 16, 2025 - 22:52 PDT

Investigating

We regret to inform you that our platform is currently experiencing an outage. Our technical teams are actively working to resolve the issue as quickly as possible.
Customer Impact:
• Inability to access the platform
• Disruption in service functionalities
• Potential delays in data processing and reporting

We understand the inconvenience this causes and appreciate your patience as we work to restore full service. We will provide regular updates on our progress.

Thank you for your understanding and continued support.
Posted Aug 16, 2025 - 22:36 PDT