The issue has been identified and a fix is being implemented.
Posted Mar 24, 2026 - 11:23 PDT
Update
Investigating
We are currently investigating an issue where some APIs are returning data in an unexpected format.
This issue is primarily impacting notifications functionality. Other services listed may experience limited or indirect impact.
In some cases, this may affect how information is displayed in mobile applications, including balance-related information.
Our team is actively working to identify the root cause and determine the appropriate fix.
Posted Mar 24, 2026 - 10:52 PDT
Update
Investigating
We are currently investigating an issue where some APIs are returning data in an unexpected format.
This may impact notifications functionality, and in some cases may affect how information is displayed in mobile applications, including balance-related information.
Our team is actively working to identify the root cause and determine the appropriate fix.
Posted Mar 24, 2026 - 10:50 PDT
Investigating
We are currently experiencing a partial outage due to high error rates in our APIs. This issue is impacting some of our customers and may affect the performance of certain services.Our technical teams are actively investigating the problem and working diligently to resolve it as quickly as possible.
Customer Impact: Possible Failed API requests across Punchh API’s • Timeouts or errors displayed in the mobile app when navigating • to different pages • Timeouts or errors displayed when managing loyalty profile or • rewards online • Timeouts or errors for loyalty functionality at the POS • Timeouts or errors from Punchh Platform Functions API • Failed Redemptions • Failed Checkins • Failed Guest Lookups • Failed signups
We apologize for any inconvenience this may cause and appreciate your patience. We will provide regular updates as we make progress. Thank you for your understanding and continued support.