A fix has been implemented and we are monitoring the results.
Posted Jul 07, 2025 - 18:07 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 07, 2025 - 18:07 PDT
Investigating
We are currently experiencing elevated response times in our APIs, resulting in downgraded performance that may impact your experience. Our team is actively working to identify and resolve the issue as quickly as possible.
Customer Impact:
Possible Failed API requests across Punchh API's • Timeouts or errors displayed in the mobile app when navigating to different pages • Timeouts or errors displayed when managing loyalty profile or rewards online • Timeouts or errors for loyalty functionality at the POS • Timeouts or errors from Punchh Platform Functions API • Failed Redemptions • Failed Checkins • Failed Guest Lookups • Failed signups
We apologize for any inconvenience this may cause and appreciate your patience. We will provide regular updates as we make progress. Thank you for your understanding and continued support.