The incident appears to be resolved on our end. We are currently awaiting confirmation from our external partners regarding their systems. We will continue monitoring closely and share further updates as soon as they are available.
Posted May 08, 2026 - 05:33 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 08, 2026 - 04:19 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 07, 2026 - 18:15 PDT
Investigating
We are currently experiencing a partial outage due to high error rates in our APIs. This issue is impacting some of our customers and may affect the performance of certain services.Our technical teams are actively investigating the problem and working diligently to resolve it as quickly as possible.
Customer Impact: Possible Failed API requests across Punchh API’s • Timeouts or errors displayed in the mobile app when navigating • to different pages • Timeouts or errors displayed when managing loyalty profile or • rewards online • Timeouts or errors for loyalty functionality at the POS • Timeouts or errors from Punchh Platform Functions API • Failed Redemptions • Failed Checkins • Failed Guest Lookups • Failed signups
We apologize for any inconvenience this may cause and appreciate your patience. We will provide regular updates as we make progress. Thank you for your understanding and continued support.