Monitoring is ongoing, and system stability has been consistently maintained. No anomalies have been detected.
Posted Dec 17, 2025 - 07:58 PST
Update
We continue to monitor the system closely, and all services remain stable with no further impact observed.
Posted Dec 17, 2025 - 06:14 PST
Update
We are continuing to monitor the system following the implemented fix and will provide further updates as the situation is monitored.
Posted Dec 17, 2025 - 05:15 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 17, 2025 - 04:17 PST
Update
UPDATE:
Additional Customer Impact: •Eligible users may not receive rewards or offers as expected. •Users may be incorrectly included in or excluded from segments.
Posted Dec 17, 2025 - 04:01 PST
Update
UPDATE: We are currently experiencing delays in database syncing within our internal data sources. Our team is working diligently to resolve this issue as quickly as possible. Delays in campaign processing • The Punchh Dashboard will show that your campaign is scheduled instead of processing or processed after than the scheduled start time • Delays in dashboard data/reporting including campaigns (Campaign Performance Page) • Some APIs may not be showing the latest data.
Posted Dec 17, 2025 - 03:22 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 17, 2025 - 03:21 PST
Update
We are continuing to investigate this issue.
Posted Dec 17, 2025 - 03:06 PST
Investigating
We are currently experiencing delays in database syncing within our internal data sources. Our team is working diligently to resolve this issue as quickly as possible. Delays in campaign processing • The Punchh Dashboard will show that your campaign is scheduled instead of processing or processed after than the scheduled start time • Delays in dashboard data/reporting including campaigns (Campaign Performance Page)
Posted Dec 17, 2025 - 03:00 PST
This incident affected: Background Processes (Campaigns, Internal Data Sync).