Punchh Platform Campaign Processing Delays

Incident Report for Punchh

Identified

We are currently experiencing an issue with badge count refresh in the app. Our team is actively working to resolve this as quickly as possible.
Customer Impact:
• Badge count may not refresh correctly and may display an outdated value in the app
• No impact on mass campaign notifications — they are being delivered as expected
• There are no delays in campaign processing or delivery
We apologize for any inconvenience caused and appreciate your patience. Further updates will be shared as more information becomes available. Thank you for your understanding.
Posted Mar 19, 2026 - 05:07 PDT

Investigating

We are currently investigating this issue.
Posted Mar 19, 2026 - 05:07 PDT

Identified

We are currently experiencing an issue with badge count refresh in the app. Our team is actively working to resolve this as quickly as possible.
Customer Impact:
 • Badge count may not refresh correctly and may display an outdated value in the app
 • No impact on mass campaign notifications — they are being delivered as expected
 • There are no delays in campaign processing or delivery
We apologize for any inconvenience caused and appreciate your patience. Further updates will be shared as more information becomes available. Thank you for your understanding.
Posted Mar 19, 2026 - 05:06 PDT

Investigating

We are currently experiencing delays in processing campaigns. Our team is actively working to resolve the issue as quickly as possible.
Customer Impact:
• Campaigns may take longer than usual to be sent out.
• You might experience delays in receiving real-time data and updates.
• The Punchh Dashboard will show that your campaign is scheduled instead of processing or processed after than the scheduled start time
• If you're still seeing this behavior 2 hours after the scheduled start time, please submit a support case

We apologize for any inconvenience this may cause and appreciate your patience. Updates will be provided as more information becomes available. Thank you for your understanding.
Posted Mar 19, 2026 - 04:32 PDT