Scheduled maintenance, no downtime is expected

Incident Report for Punchh

Resolved

This incident has been resolved.
Posted May 01, 2020 - 05:54 PDT

Investigating

We are currently investigating this issue.
Posted May 01, 2020 - 02:50 PDT