Punchh Platform - IRS Recommendations Temporarily Unavailable

Incident Report for Punchh

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 08:16 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2025 - 08:07 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 25, 2025 - 08:05 PDT

Investigating

We regret to inform you that our platform is currently experiencing an outage. Our technical teams are actively working to resolve the issue as quickly as possible.
Customer Impact:
• Beta Customers will be unable to access the platform
• Disruption in service functionalities

We understand the inconvenience this causes and appreciate your patience as we work to restore full service. We will provide regular updates on our progress.

Thank you for your understanding and continued support.
Posted Mar 25, 2025 - 06:54 PDT