Delayed Processing of Campaigns
Incident Report for Punchh
Resolved
Campaigns completed successfully.
Posted Jan 31, 2020 - 11:32 PST
Monitoring
Campaign requests are higher than normal this week and so there is some delay in campaign processing. Expect campaigns to take slightly longer than expected today.
Posted Jan 31, 2020 - 10:35 PST
This incident affected: Background Workers.