Ongoing Cloudflare Outage Affecting Services

Incident Report for Punchh

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 13:53 PDT

Monitoring

Status Update
We are currently tracking an issue related to Cloudflare, which is impacting portions of our service. While our APIs remain fully operational, some customers may experience slower performance in the dashboard.

At this time, we are not aware of any issues with points processing. However, if service disruption occurs due to Cloudflare's outage, points may temporarily display as "0" at the POS.

Our cross-functional teams are actively engaged on an incident bridge and closely monitoring the situation. We will continue to provide updates as we learn more or if conditions change.
Posted Aug 21, 2025 - 11:57 PDT
This incident affected: Partners (Cloudflare) and Web Components (Management Dashboard).