Punchh Platform Outage

Incident Report for Punchh

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 10:03 PST

Update

Cloudflare has resolved the underlying issue, and our services are operating normally. We are continuing to monitor for any further anomalies and remain in close communication with Cloudflare to address any potential challenges promptly.
Posted Nov 18, 2025 - 08:09 PST

Monitoring

A fix has been implemented by Cloudflare, and our services are expected to return to normal shortly. We are actively monitoring the systems to ensure stability and confirm that all functionalities are operating as expected.
Posted Nov 18, 2025 - 06:47 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 18, 2025 - 06:47 PST

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 06:17 PST

Investigating

We are currently experiencing service degradation due to an ongoing Cloudflare outage. Our teams are in continuous communication with Cloudflare to resolve this issue as quickly as possible. This disruption is impacting some of our customers and may affect the performance of certain services.

Customer Impact
You may experience the following issues:

Possible failed API requests across Punchh APIs
Timeouts or errors displayed in the mobile app when navigating between pages
Timeouts or errors when managing loyalty profiles or rewards online
Timeouts or errors for loyalty functionality at the POS
Timeouts or errors from Punchh Platform Functions API
Failed redemptions
Failed check-ins
Failed guest lookups
Failed sign-ups


We sincerely apologize for any inconvenience this may cause and appreciate your patience. We will provide regular updates as we make progress. Thank you for your understanding and continued support.
Thank you for your understanding and continued support.
Posted Nov 18, 2025 - 06:13 PST