Staggered Start campaigns delivering later than scheduled

Incident Report for Punchh

Update

Update: Brands that want to keep using Staggered Start can set the campaign's Fallback Timezone to Eastern Time (US & Canada). Campaigns set up this way go out at the selected local time in each time zone. Otherwise, we recommend a standard scheduled send time until the fix, planned for September 29, is released.
Posted Sep 11, 2026 - 10:13 PDT

Identified

Campaigns scheduled with the "Staggered start (based on recipient time zone)" option are being delivered later than the local time selected, typically by about 3 hours. Campaigns are still sending; only the timing is affected. Standard scheduled campaigns are not affected. A fix is planned for the September 29 release. Until then, we recommend using a standard scheduled send time. If you have questions about a specific campaign, please contact your Customer Success Manager.
Posted Sep 11, 2026 - 07:54 PDT
This incident affects: Background Processes (Campaigns).